👉 Sådan laver du gamle WordPress-temaer, der er kompatible med nye versioner - IsItWP

Behøver WordPress Admin Bar en mere dropdown?

>

Så du vil gøre dine gamle WordPress-temaer kompatible med nyere versioner af WordPress. Med WordPress 3.0 lige rundt om hjørnet er temakompatibilitet noget på mange menneskers sind. Det er ret simpelt: gør absolut ingenting.

Jeg har lavet WordPress temaer siden omkring WordPress 2.3 blev udgivet, og gæt hvad? Disse temaer arbejder stadig i dag og der er intet jeg brug for at gøre for at holde dem i gang med nyere versioner af WordPress.

  • Vil de have threaded kommentar funktionalitet (ca. 2,7)? Nej, de har sandsynligvis stadig "single level" kommentarer.
  • Vil det bruge post_thumbnails at håndtere post thumbnails (ca. 2.9)? Nej, men ikke alle temaer bruger alligevel efter miniaturebilleder.
  • Vil de have den nye navigationsmenuer, brugerdefineret header og baggrundsbilleder indført i den kommende WordPress 3.0? Nej, og husk ikke hvert tema vil have behov for brugerdefinerede baggrund eller header billeder.

De fleste af disse funktioner vil jeg overveje valgfri. Med måske undtagelsen fra de trådte kommentarer eller det nye menusystem, vil mange temaer ikke engang behøve eller være designet omkring ting som brugerdefinerede miniaturebilleder eller headerbilleder.

Så vær venlig at holde op med at bekymre dig om dit tema vil bryde, når du opgraderer WordPress. Ingen lovovertrædelse til mine plugin-udvikler venner, men 99% af tiden, WordPress bryder med en kerneopgradering, det er en plugin-fejl (og den har sandsynligvis det på grund af mistænkte plugin-kodningspraksis).

Hvis et tema har en brugerdefineret funktion, der er i konflikt med en ny WordPress-funktion, kan det samme ske med temaer, så det er muligt. Dette er nok den eneste "bug", jeg nogensinde har hørt om, ske med en ny kerneropgradering (og ikke alle temaer anvendte get_categories-funktionen).

For at være ærlig, Jeg har aldrig set et tema helt pause, og det vil jeg nok aldrig. Jeg ville være interesseret i at høre dine tanker i kommentarerne, hvad synes du om at gøre temaer "kompatible" med nye versioner? Har du nogensinde set et temapause på grund af en ny WordPress-version?

Hvis du vil have dit WordPress-tema til at udnytte de nye funktioner, der vil være tilgængelige, når WordPress 3.0 er udgivet, har denne artikel nogle gode oplysninger om integrering af brugerdefinerede baggrunde, overskrifter, menuer, blandt andet.

Like this post? Please share to your friends:
Skriv et svar

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: