👉 Skal du installere plugins ikke testet med din WordPress-version?

Sådan laver du en WordPress-blog

Ofte spørger vores brugere os om advarslen om, at et plugin ikke testes med deres version af WordPress. Skal du installere plugins, der plugin? eller find et andet plugin? I denne artikel vil vi diskutere, hvorfor du skal installere plugins, der ikke testes med din version af WordPress? Hvad betyder det, og hvordan kan du hjælpe WordPress-fællesskabet?

Når du installerer et plugin fra WordPress admin area, kan du muligvis se en advarsel om, at et plugin ikke er testet med din version af WordPress.

Hvordan WordPress får ikke testet information?

Det officielle WordPress plugin repository er den største samling af gratis og open source WordPress plugins. Ved indsendelse af pluginet skal forfattere indsende en "readme" -fil med deres plugins. Denne readme-fil bruges derefter af plugin-biblioteket til at generere plugin-side.

Readme-filen indeholder "Testet op til" tag, som bruges til at vise oplysningerne. Pluginforfattere forventes at holde disse oplysninger ajour.

Dette betyder, at med hver udgivelse af WordPress skal pluginforfattere teste deres plugins og opdatere readme-filerne til deres plugins.

Hvorfor Opdater ikke denne information?

Mange pluginforfattere opdaterer ikke deres readme-filer overhovedet, selv når de tester deres plugin med den nyeste version.

I en ideel verden ønsker vi alle pluginforfattere at opdatere disse oplysninger. Men vi lever ikke i en ideel verden.

Husk at disse plugins er gratis, og du betaler ikke forfattere til at downloade og bruge dem. Pluginforfattere føler sig mindre tilbøjelige til at opdatere readme-filen med hver udgivelse. De er normalt optaget af deres fuldtidsjob og betalte udviklingsprojekter.

Video Tutorial

Tilmeld dig WPBeginner

Hvis du ikke kan lide videoen eller har brug for flere instruktioner, skal du fortsætte med at læse.

Skal jeg installere disse plugins?

Ja du burde. Bare fordi en pluginforfatter ikke opdaterede deres readme-fil, betyder det ikke, at de ikke har testet deres plugin, eller at plugin'et ikke virker med den nyeste version af WordPress.

Hvis du har hørt om et plugin på WPBeginner, kan du sikkert gå ud fra, at vi testede pluginet med den nyeste version af WordPress. Hvis artiklen, du ser på, blev offentliggjort ret for nylig, betyder det, at pluginet er kompatibelt med den nyeste version af WordPress.

På den anden side, hvis et plugin ikke er blevet opdateret i mere end to år, betyder det, at pluginet sandsynligvis er blevet forladt. I så fald skal du ikke installere plugin'et.

Det ville være interessant at bemærke, at mange plugins, der ikke er blevet opdateret i mere end to år, stadig virker meget godt. Du skal dog installere dem på egen risiko.

Hvordan kan du hjælpe?

Du kan installere plugin'et på dit WordPress-websted og teste det ud. Hvis det virker som forventet, så kom tilbage til pluginets side. Log ind med dit WordPress.org brugernavn og kodeord. Dernæst rulle ned til bunden af ​​siden, hvor du vil se kompatibilitetsafsnittet.

Du skal blot vælge din WordPress-version, plugin-version og derefter klikke på Works-knappen. Ved at lade andre brugere vide, at du har testet pluginet, og det fungerer som lovet.

Du kan også kontakte plugin-forfatteren og bede dem om at opdatere deres plugin's readme-fil

Hvad skal man gøre, når et plugin er brudt?

Endnu engang vil vi gerne minde vores brugere om, at hvis det er et gratis plugin, så har plugin-forfatteren givet det som en basis. Der er ingen garanti, ikke engang den underforståede garanti for fitness. Men spørgsmålet er, hvordan du kan hjælpe lokalsamfundet med at bryde plugins?

I stedet for at efterlade en hård kommentar til pluginets supporttråd, kan du efterlade en konstruktiv og nyttig feedback. Se vores vejledning om, hvordan du korrekt beder om WordPress-support og få det.

Før du gør noget, skal du prøve at installere plugin'et på forskellige live eller lokale WordPress-installationer. Sørg for, at du også kan gengive den samme fejl på andre installationer.

Når du er sikker på, at plugin'et er brudt, skal du blot beskrive fejlen i en supporttråd og lade den være til plugin-forfatter eller i fællesskab for at svare. Hvis du ikke får svar, kan du prøve at nå ud til pluginforfatteren. De fleste pluginforfattere har kontaktoplysninger på deres WordPress.org profilsider.

Hvis disse trin fejler, skal du være velkommen til at besøge pluginets side og stemme plugin'et, der er brudt under kompatibilitetsafsnittet.

Vi håber, at denne artikel hjalp med at besvare dine spørgsmål om, hvorvidt du skal installere plugins, der ikke er testet med din version af WordPress.

Hvis du kunne lide denne artikel, bedes du abonnere på vores YouTube-kanal til WordPress-video-øvelser. Du kan også finde os på Twitter og Google+.

Like this post? Please share to your friends:
Skriv et svar

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: